Intermittent API outage due to an internal DNS issue

Incident Report for Databento

Resolved

This incident has been resolved.
Posted Jul 24, 2026 - 23:20 UTC

Monitoring

We've implemented a fix internally and the system looks healthy again. We'll continue to monitor.
Posted Jul 24, 2026 - 23:04 UTC

Identified

We're investigating an issue with an internal DNS server, which is causing intermittent API 500 errors. We expect this to be resolved within the next 15 minutes.
Posted Jul 24, 2026 - 23:03 UTC
This incident affected: Portal, Historical, and FTP.