Consistent 504 timeout on the Historical API

Incident Report for Databento

Update

We are continuing to monitor.
Posted Aug 04, 2026 - 14:08 UTC

Monitoring

We've applied mitigations to the historical service and continue to monitor for timeouts.
Posted Aug 04, 2026 - 09:57 UTC

Investigating

We are investigating an issue where the Historical API is showing timeout errors.
Posted Aug 04, 2026 - 07:47 UTC
This incident affects: Historical.