Batch jobs being queued indefinitely

Incident Report for Databento

Resolved

The incident has been resolved, delayed batch jobs have been processed, and newly-submitted jobs are processing normally.
Posted Aug 21, 2026 - 13:30 UTC

Monitoring

We have failed over to our secondary scheduler and the job queue is being drained.
Posted Aug 21, 2026 - 10:58 UTC

Investigating

We are investigating an issue where batch jobs are not being dequeued for processing.

The streaming API is not affected.
Live data is not affected.
Posted Aug 21, 2026 - 09:56 UTC
This incident affected: Historical.