Batch job downloads are temporarily unavailable

Incident Report for Databento

Resolved

This incident has been resolved.
Posted May 14, 2026 - 01:06 UTC

Monitoring

We have restored our batch job storage system, and jobs are starting to process again. We're continuing to monitor for further issues.
Posted May 14, 2026 - 00:56 UTC

Identified

We have identified an issue with our batch job storage system. Batch jobs are currently unavailable to download, and are not being processed. Jobs can still be submitted, but they will be queued up to process until the incident is resolved.
Posted May 14, 2026 - 00:45 UTC
This incident affected: Historical and FTP.