Historical data delays for XEUR.EOBI

Incident Report for Databento

Resolved

The issue has been resolved
Posted May 26, 2026 - 11:37 UTC

Investigating

We are investigating an issue causing historical and intraday data to be released with a larger than normal delay on XEUR.EOBI
Posted May 26, 2026 - 08:12 UTC
This incident affected: Historical.