Unrecovered gaps in Live data for Nasdaq TotalView

Incident Report for Databento

Postmortem

Yesterday, at 18:35:29 UTC (2:35pm ET), our primary live feed handler for Nasdaq TotalView (XNAS.ITCH) had a network gap during a microburst on the feed. Recovery attempts failed under high load, causing missed packets and triggering the F_MAYBE_BAD_BOOK flag on the MBO schema.

Under normal circumstances, we would promote our secondary servers to handle new connections, and MBO users would've been able to reconnect with the snapshot=1 parameter to pick up the current state of the book from the new healthy server. However, a monitoring issue earlier in the day prevented us from bringing the secondary server online during trading hours. We've since fixed the monitoring gap and are addressing the root cause by allocating more resources to our recovery system. In the longer term, we’ve scheduled enhancements to the Nasdaq TotalView feed handler, similar to the OPRA improvements released last month.

Posted Oct 31, 2025 - 01:31 UTC

Resolved

Today at 18:35:29 UTC (2:35pm ET), our primary live gateway for Nasdaq TotalView (XNAS.ITCH) had an unrecovered gap while processing upstream data. This manifested in MBO data having the `F_MAYBE_BAD_BOOK` flag set, and MBP-10 & MBP-1 books being unstable while they underwent natural refresh. The missing data is not recoverable on the customer side.

This did not impact historical data or captures, nor did it impact other feeds such as Nasdaq Basic.
Posted Oct 29, 2025 - 21:47 UTC
This incident affected: Live US Equities - Secaucus NY4.