High latencies on MBP-10 for GLBX.MDP3

Incident Report for Databento

Resolved

This incident has been resolved.
Posted Apr 23, 2026 - 21:25 UTC

Monitoring

Feed handler latencies for MBP-10 look reverted back to normal. We continue to monitor for any abnormalities.
Posted Apr 23, 2026 - 18:23 UTC

Update

We are continuing to work on a fix for this issue.
Posted Apr 23, 2026 - 18:17 UTC

Identified

We have identified an issue where high latencies are being observed for some MBP-10 subscriptions on GLBX.MDP3. Other schemas are not affected

Affected customers are instructed to disconnect manually and reconnect.
Posted Apr 23, 2026 - 18:16 UTC
This incident affected: Live (Live CME - Aurora DC3).