Batch job processing delayed

Incident Report for Databento

Resolved

This incident has been resolved.
Posted Jul 27, 2026 - 21:28 UTC

Update

We have taken additional internal steps to remediate this issue, and we're seeing improved batch job processing times (as of 10 minutes ago).
Posted Jul 27, 2026 - 17:12 UTC

Monitoring

The batch job processing system has caught up on the backlog of jobs, we're continuing to monitor the system.
Posted Jul 27, 2026 - 04:18 UTC

Identified

Our batch job processing system fell behind due to internal storage degradation. Processing is resuming with the backlog of jobs. (There is no need to re-submit any jobs.)
Posted Jul 27, 2026 - 02:53 UTC
This incident affected: Historical.