Batch job processing delayed

Incident Report for Databento

Resolved

Batch job processing delays have been resolved.
Posted May 22, 2026 - 14:15 UTC

Identified

Batch job processing is delayed, small jobs may take longer to finish than usual. There is no need to re-submit jobs. We expect this to be resolved within 1-2 hours.
Posted May 22, 2026 - 13:32 UTC
This incident affected: Historical.