Databento portal and historical API down

Incident Report for Databento

Monitoring

We identified an issue with one of the storage metadata servers affecting IO operations on our storage cluster.
This resulted in a cascade of effects causing our web services to hang.
We have failed over the problem server and all historical API and web services are back operational.
Batch job processing was delayed during the incident, but jobs are now progressing.

We are continuing to monitor for any issues.
Posted Aug 06, 2026 - 15:05 UTC

Update

We are continuing to work on a fix for this issue.
Posted Aug 06, 2026 - 12:53 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Aug 06, 2026 - 11:33 UTC

Investigating

We are investigating an issue with the historical API and Databento web portal
Posted Aug 06, 2026 - 11:13 UTC
This incident affects: Portal and Historical.