Batch job processing delayed

Incident Report for Databento

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 29, 2026 - 10:23 UTC

Identified

Our batch job processing system fell behind, processing is resuming with the backlog of jobs. (There is no need to re-submit any jobs.)

We're expecting the system to be caught up by 10:00 UTC.
Posted Jul 29, 2026 - 08:51 UTC
This incident affects: Historical.