Delays in processing batch downloads

Incident Report for Databento

Resolved

This incident has been resolved.
Posted Feb 25, 2026 - 04:50 UTC

Monitoring

There are currently delays in processing batch downloads, we believe the root cause of the issue with our system has been resolved and it is catching up. We expect processing to return to normal within 2 hours.
Posted Feb 25, 2026 - 02:20 UTC
This incident affected: Historical.