Historical API timeouts

Incident Report for Databento

Resolved

This incident has been resolved.
Posted May 20, 2026 - 21:00 UTC

Update

XNAS.ITCH data is available again as usual, we're continuing to monitor our historical API for performance issues.
Posted May 20, 2026 - 17:50 UTC

Monitoring

XNAS.ITCH data is available again as usual, we're continuing to monitor our historical API for performance issues.
Posted May 20, 2026 - 17:50 UTC

Update

The API timeouts have been mitigated, however XNAS.ITCH data for 2026-05-19 (Tuesday) and 2026-05-20 (today) is temporarily unavailable.
Posted May 20, 2026 - 16:01 UTC

Update

XNAS.ITCH data after 2026-05-19 is temporarily unavailable while we remediate the issue
Posted May 20, 2026 - 15:34 UTC

Identified

We're investigating issues with our historical API, users may see timeouts or HTTP 504 errors while this issue is ongoing.
Posted May 20, 2026 - 14:54 UTC
This incident affected: Historical.