Historical batch job processing is delayed

Incident Report for Databento

Resolved

This incident has been resolved.
Posted Apr 07, 2026 - 20:58 UTC

Identified

Batch jobs for historical data are currently being processed slowly. During this period, jobs may appear as "queued" or have a "stuck" completion percentage.

No additional action is needed to resume these jobs, and they will be processed in first-in-first-out order so there is no need to re-submit them.
Posted Apr 07, 2026 - 17:20 UTC
This incident affected: Historical.