Historical API delays for GLBX.MDP3

Incident Report for Databento

Update

Historical data for GLBX.MDP3 is continuing to catch up. Data from 2026-06-10 has been made available (T-1 complete).
Posted Jun 11, 2026 - 09:06 UTC

Identified

We're aware of delays publishing intraday historical data for CME Globex (GLBX.MPD3). This is related to the storage outage from earlier today.
Posted Jun 11, 2026 - 00:01 UTC
This incident affects: Historical.