Investigating intermittent timeouts on historical APIs

Incident Report for Databento

Resolved

This incident has been resolved.
Posted Apr 28, 2026 - 22:26 UTC

Monitoring

We have taken additional steps to resolve the slow operations on the storage cluster.
We will continue to monitor for issues.
Posted Apr 28, 2026 - 00:34 UTC

Identified

We are still experiencing performance issues on our storage cluster.
This is causing intermittent issues on the historical API and delays to historical data availability.

We are working on a fix.
Posted Apr 27, 2026 - 14:39 UTC

Monitoring

We have taken steps to resolve the slow operations on the storage cluster.
We will continue to monitor for issues.
Posted Apr 27, 2026 - 12:56 UTC

Identified

We have taken action to mitigate the impact.
Our systems engineers have identified the root cause and are working to resolve the issue.

Customers may continue to experience timeouts and errors from the historical API.
Posted Apr 27, 2026 - 10:38 UTC

Update

We are continuing to investigate this issue.
Posted Apr 27, 2026 - 10:14 UTC

Investigating

We are currently investigating intermittent issues on our historical API.
We believe this is due to slow reads on our storage cluster.
Posted Apr 27, 2026 - 10:13 UTC
This incident affected: Historical.