Platform email sending delays

Incident Report for Databento

Resolved

This incident has been resolved.
Posted Jun 05, 2026 - 00:00 UTC

Monitoring

Our email service provider states that they have deployed a fix, and are sending queued emails.

Users trying to sign up may need to resend their confirmation code if the original one expired.
Posted Jun 04, 2026 - 23:41 UTC

Identified

One of our email service providers is experiencing delays. This includes emails as part of the signup process, team invites, and budget alerts.

Support and sales emails are not impacted: you can still reach us through any of the options on https://databento.com/support
Posted Jun 04, 2026 - 22:51 UTC
This incident affected: Portal.